Google Chrome 50 OS Requirement Changes

Standard

Chrome50

Earlier today, Google Chrome 50 was released. With this release, there are some changes to the platforms that Google Chrome is supported on.

Below is some detail on this, & how it could affect you.

Forewarning

This post from November 2015 advises:

Today, we’re announcing the end of Chrome’s support for Windows XP, as well as Windows Vista, and Mac OS X 10.6, 10.7, and 10.8, since these platforms are no longer actively supported by Microsoft and Apple. Starting April 2016, Chrome will continue to function on these platforms but will no longer receive updates and security fixes.

Attempting to run Chrome 50 on an OS less than 10.9 will show the below:

Screen Shot 2016-04-13 at 10.26.29 PM

With quick look also showing an issue with the app:

Screen Shot 2016-04-13 at 10.26.14 PM

A poke inside Chrome’s info.plist (Google Chrome.app/Contents/Info.plist) shows this being set via the LSMinimumSystemVersion key.

Screenshot 2016-04-13 22.30.18

Deployment

If you’re deploying Chrome to the Macs you manage, then there are some things to bear in mind.

Munki

Munki will read he LSMinimumSystemVersion key from within the applications info.plist, & will set the OS requirements as needed.

Casper

If you’re manually packaging Chrome (why?) for use within Casper, you’ll want to set the OS requirements for the PKG/DMG either via the JSS or Casper Admin.

Screenshot 2016-04-13 22.37.20

As Casper has no concept of minimum OS version, you’ll need to add each OS it can be installed on.

Therefore, for Chrome the Operating System Requirement field should have: 10.9.x,10.10.x, 10.11.x.

Of course, you can manage this too with your smart group scoping that is used to install Chrome, but by setting the Operating System Requirements within Casper then a PKG/DMG cannot be installed via other Casper means (Imaging, Remote, Self Service).

Google Chrome.jss.recipe

If you’re using the Google Chrome.jss.recipe, then please update your AutoPKG repo’s.

I filed a PR that has since been merged which adds these OS requirements to the recipe & therefore they will be added to the Chrome PKG when uploaded to the JSS.

Artisanal Update Scripts

If you’ve written your own Chrome update scripts, you may want to add some logic based off of the LSMinimumSystemVersion key so your script does not install onto an OS that Chrome will no longer run on.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.